Navit für den Pre?

      Da der Index von OSM was Strassen und Hausnummer angeht zuweilen unzureichende Detailschärfe besitzt und ich glaube Hausnummer in NAVit noch immer nicht sauber "an-navigiert" werden können, nutze ich Homebrew GoogleMaps für die Adressuche und dort übergebe ich die gefunden Koordinaten an Navit. Voraussetzzung hierfür ist NavitMaps, ebenfalls Homebrew.
      Auch ich habe Navit auf meinem Pre2 installiert und was mir beim Testen negativ aufgefallen ist, dass die Stimme dauernd durchgibt "Jetzt leicht links auf der XXX-Straße, jetzt leicht recht, jetzt leicht links, nach 200 Metern leicht links auf der XXX-Straße", usw. obwohl ich mich auf einer Hauptstraße befinde und erst mal gar nicht abbiegen muss. Diese Ansagen gab es sogar andauernd auf der 4 Kilometer langen und kerzengeraden Strecke von unserem Stadtteil zum nächsten. Gibt es da eine Einstell-Möglichkeit, dass nur die wichtigen Abbiegepunkte angesagt werden? Denn so nervt es zum einen und zum anderen bekommt man oft gar nicht mit, wann man wirklich abbiegen muss.
      Radio geht ins Ohr, Fernsehen geht ins Auge
      Habe versucht, Navit auf meinem Pre3 zum Laufen zu bringen. Leider war bei den englischen OSM Daten keine vernünftige Straßeneingabe möglich, wordurch aus der Navigation nichts wurde. Am Touchpad ging es (wenngleich nur im kleinen Fenster), da gibts aber bekanntlich kein GPS. Haben uns dann mit dem iPhone meiner Freundin zum gewünschen Ziel manövriert.

      Ich verwende Navit daher nicht mehr und kann Dir also auch leider nicht helfen.

      Der "regen" Beteiligung und den "vielen" Antworten zufolge würde ich mal vermuten, dass es hier nicht mehr viele Leute gibt, die Navit noch am Pre verwenden.
      ---
      Dieser Beitrag spiegelt meine persönlichen Meinungen und Erfahrungen wider und nicht notwendigerweise die der Forenbetreiber.
      Auch hier danke für Deine Antwort.
      Demnach scheint es so, dass es für WebOS keine vernünftige Navi-Alternative gibt :schnieft: Wenn ich mit meiner Frau gemeinsam im Auto unterwegs bin, nutzen wir ihr Galaxy-Tablet, die Navi-App funzt einwandfrei. Hätte aber gerne eine Alternative für "Alleinfahrten" gehabt.....
      Radio geht ins Ohr, Fernsehen geht ins Auge
      Auf meinem Pre- lief damals Navit mit dem Kartenmaterial vom Marco Polo (siehe Navit für den Pre?)

      Auf dem Pre3 hab ich Navit nicht mehr im Einsatz, da ich mir NDrive besorgt und die Karten dazu gekauft habe. Das läuft sehr gut.NDrive für den Pre3?
      Besucht die PUG-Hamburg. Lockerer Stammtisch jeden zweiten Mittwoch im Monat. ALLE Smartphone-Systeme (webOS, PalmOS, Android, iOS, Blackberry, WP7, WinMob, Symbian, Maemo, Meego, Openmoko, Bada, u.a.) willkommen. amile.de/pug
      Bei mir läuft NAvit noch ziemlich problemlos auf dem Pre3. Seit dem letzten Update läuft die Positionsinterpolation auch in Strassentunneln (ohne GPS-Signal) vernünftig weiter. Hausnummern gehen grösstenteils nicht als Zielvorgabe, aber Strassen relativ gut. Da gibt es aber noch das geniale NavitMaps, über dass man Positionen von Google-Abfragen an Navit weitergeben kann, damit gehen auch genaue Adressen.
      Gelegentlich gibt es Holperstellen im zugrundeliegenden Kartenmaterial von OpenStreetMap. Meist sind zwei Segmente einer durchgehenden Strasse nicht richtig miteinander verbunden,, das erzeugt dann "sinnlose" Navi-Anweisungen. Wenn es direkt vor der Haustür ist, kann man ja mal versuchen, bei openstreetmap die Änderungen einzugeben oder aktive OSMler darauf hinzuweisen.
      Die Vorweg-Abbiegehinweise kann man in der Navit.xml (Konfigurationsdatei) auch abstellen. Dazu das Navit-Wiki studieren.

      Navit 0.5.0.5287-1: installiert, startet auch, aber kein GPS-Profil vorhanden

      Hallo zusammen,
      bei meinem letzten Besuch bei Preware wurde mir ein Update von NAVIT angeboten, dieses habe ich auch installiert, der Startbildschirm hat auch neue Icons, ich kann alle Menüpunkte durchgehen, Karten werden angezeigt (Navit Maps installiert), nur: es kann kein GPS-Profil ausgewählt werden (Menüpunkt: Einstellungen - erweitert - Fahrzeug). Habe es schon deinstalliert, per USB das komplette Verzeichis gelöscht (\appdata\org.webosinternals.navit) und neu installiert, mehrmals mit und ohne Neustart, aber keine Änderung. Weiss jemand einen Rat? Oder wo bekomme ich eine ältere Version her, die ja einwandfrei lief, sogar aus der Homebrew-GoogleMapsApp heraus!

      Grüße aus Köln vom Franz
      Hier gibt es die alten Versionen:[url]http://ipkg.preware.org/feeds/webos-internals/armv7/[/url]
      Mit Preware manuell installieren.

      Bei einem Update oder Downgrade wird aber die navit.xml (Konfigurationsdatei) nicht gelöscht. Normalerweise steht dort die GPS-Einstellung, da muss man nichts im Menü einstellen. Am besten mal alles deinstallieren und auch die NAvit-Dateien in appdata löschen. Evtl.die maps-DAtei vorher sichern, damit man die nicht wieder runterladen muss.
      Das habe ich ja alles schon gemacht! Danke für den Link mit den Versionen! Damit konnte ich nämlich ausprobieren, welche Version geht und welche nicht, Ergebnis:
      org.webosinternals.navit_0.5.0.5243-2_armv7.ipk
      org.webosinternals.navit_0.5.0.5287-1_armv7.ipk

      funktionieren nicht, d.h. Navit startet, es wird auch die Karte angezeigt, aber GPS fehlt (Menüpunkt: Einstellungen - erweitert - Fahrzeug).

      org.webosinternals.navit_0.5.0.4787-2_armv7.ipk, diese Version funktioniert einwandfrei!

      Palm Pre Plus mit WebOs 1.4.5 (WebOs Doctor)

      Gruß Franz aus Köln
      Habe das jetzt selbst mal auf meinem Ur-Pre mit 1.4.5 ausprobiert. Unter Fahrzeug steht wirklich nichts, aber da stehen unter webOS2.2.4 die Routingoptionen (Fussgänger, Pferd, ohne Autobahn etc.)
      Das GPS geht bei mir. Allerdings habe ich ein Uralt-Layout bekommen, habe aber auch nicht alle Dateien gelöscht, um die Karte nicht neu zu laden. Die Initaialisoierungsroutine scheint wirklich nach allen möglichen Leichen zu suchen. Vielleicht doch mal ALLES löschen (in appdata)?

      Mäuseturm schrieb:

      Auch ich habe Navit auf meinem Pre2 installiert und was mir beim Testen negativ aufgefallen ist, dass die Stimme dauernd durchgibt "Jetzt leicht links auf der XXX-Straße, jetzt leicht recht, jetzt leicht links, nach 200 Metern leicht links auf der XXX-Straße", usw. obwohl ich mich auf einer Hauptstraße befinde und erst mal gar nicht abbiegen muss. Diese Ansagen gab es sogar andauernd auf der 4 Kilometer langen und kerzengeraden Strecke von unserem Stadtteil zum nächsten. Gibt es da eine Einstell-Möglichkeit, dass nur die wichtigen Abbiegepunkte angesagt werden? Denn so nervt es zum einen und zum anderen bekommt man oft gar nicht mit, wann man wirklich abbiegen muss.


      diese seltsamen Fehler hatte ich auch, sind seit dem letzten Update verschwunden

      dafür bekomme ich jetzt öfters die Ansage: "Fehler! Jetzt rechts abbiegen!" Teilweise auch wenn da definitiv nichts ist wohin man abbiegen kann....
      Hallo,
      @Kunz: Habe einen 2. Pre Plus mit WebOs 2.1 installiert, dann Navit über Preware installiert, (Version 0.5.0.5287-1). Funktioniert einwandfrei. Scheint also ein Problem der WebOs-Versionen zu sein. Im Forum bei forums.webosnation.com/navit/3…1-new-stable-release.html kam die Vermutung auf, dass es etwas mit ENYO zu tun haben könnte?
      Bei meinem Pre + mit 1.4.5 habe ich ja schon mehrfach alles gelöscht und die Version 0.5.0.4787-2 läuft ja auch einwandfrei.

      Gruß Franz aus Köln

      Mäuseturm schrieb:

      Auch ich habe Navit auf meinem Pre2 installiert und was mir beim Testen negativ aufgefallen ist, dass die Stimme dauernd durchgibt "Jetzt leicht links auf der XXX-Straße, jetzt leicht recht, jetzt leicht links, nach 200 Metern leicht links auf der XXX-Straße", usw. obwohl ich mich auf einer Hauptstraße befinde und erst mal gar nicht abbiegen muss. Diese Ansagen gab es sogar andauernd auf der 4 Kilometer langen und kerzengeraden Strecke von unserem Stadtteil zum nächsten. Gibt es da eine Einstell-Möglichkeit, dass nur die wichtigen Abbiegepunkte angesagt werden? Denn so nervt es zum einen und zum anderen bekommt man oft gar nicht mit, wann man wirklich abbiegen muss.
      Hast Du möglicherweise mehrere Karten aktiviert? Dieses Problem hatte ich dann, wenn ich überlappende Karten benutzt habe. In der Liste in Navit Maps kann man heruntergeladene Karten deaktivieren, indem man einmal drauftippt. Aktive Karten bleiben fettgedruckt, deaktivierte nicht.

      Andere Frage: Weiß jemand, in welcher Datei der Text für die Sprachausgabe liegt? Z.B. "Bitte Geschwindigkeit verringern!"

      Buntbart schrieb:

      Weiß jemand, in welcher Datei der Text für die Sprachausgabe liegt? Z.B. "Bitte Geschwindigkeit verringern!"


      Irgendwo in den Unterordnern des direkten Programmverzeichnisses (media/cryptofs..../org.webosinternals.navit/...)

      EDIT: vielleicht hier: usr\palm\applications\org.webosinternals.navit\share\locale\de\LC_MESSAGES\navit.mo
      Ist aber ein binäres File , aber ein paar Strings sind drin...
      z.B. auch:
      "Last-Translator: Achim Behrens <Unknown>
      Language-Team: Martin Schaller <martin-s@sourceforge.net>"

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Kunz“ ()

      Buntbart schrieb:

      Mäuseturm schrieb:

      Auch ich habe Navit auf meinem Pre2 installiert und was mir beim Testen negativ aufgefallen ist, dass die Stimme dauernd durchgibt "Jetzt leicht links auf der XXX-Straße, jetzt leicht recht, jetzt leicht links, nach 200 Metern leicht links auf der XXX-Straße", usw. obwohl ich mich auf einer Hauptstraße befinde und erst mal gar nicht abbiegen muss. Diese Ansagen gab es sogar andauernd auf der 4 Kilometer langen und kerzengeraden Strecke von unserem Stadtteil zum nächsten. Gibt es da eine Einstell-Möglichkeit, dass nur die wichtigen Abbiegepunkte angesagt werden? Denn so nervt es zum einen und zum anderen bekommt man oft gar nicht mit, wann man wirklich abbiegen muss.
      Hast Du möglicherweise mehrere Karten aktiviert? Dieses Problem hatte ich dann, wenn ich überlappende Karten benutzt habe. In der Liste in Navit Maps kann man heruntergeladene Karten deaktivieren, indem man einmal drauftippt. Aktive Karten bleiben fettgedruckt, deaktivierte nicht.

      Das könnte möglicherweise das Problem sein, ich hatte mir neben der Deutschland-Karte auch die Rheinland-Pfalz-Karte runter geladen, da ich zunächst unseren Stadtteil Dromersheim nicht als Ziel gefunden hatte. Ich deaktiviere daher mal die Rheinland-Pfalz-Karte, mal sehen, ob es dann wieder normal funktioniert. (Wenn ich mich recht erinnere, hatte ich auch anfangs dieses Problem nicht, somit spricht das auch für ein Kartenproblem)
      Radio geht ins Ohr, Fernsehen geht ins Auge
      Nette Neuigkeiten: Nach dem Aussstieg von "noradtux" hat "72ka" die Navit-Portierung auf webOS übernommen. Das ist der tschechische Entwickler, der uns schon die neue Google Maps App gebracht hat. Aktuell ist jetzt Release 0.5.0.5337-0.1, es kann bei webosnation gefunden und gedownloadet werden. Startet noch 'ne Spur flotter auf dem Pre3 und scheint auch stabiler zu laufen.
      n3x4v3? f31n35 f02um! WinXP Ubuntu openSUSE!