Messenger auf dem Pre: ICQ & Co.

  • Ich hab schon vor über einem Jahr einen Trasport von ICQ über jabber.no nach Google Talk eingerichtet und seitdem funktioniert ICQ einwandfrei ohne jedes Extra-Programm und ohne jeden Patch.
    Das ist doch das mit Abstand Einfachste. :rolleyes:


    Hast du dafür auch ne Anleitung? Ich habe zwar einen Jabber-Account, ich habe es aber nicht hinbekommen, so einen Transport lauffähig einzurichten.


    Viele Grüße
    Frank

  • Hast du dafür auch ne Anleitung? Ich habe zwar einen Jabber-Account, ich habe es aber nicht hinbekommen, so einen Transport lauffähig einzurichten.


    Ich hatte damals ne Anleitung bei Google gefunden und das mit Hilfe von Psi eingerichtet.
    Seitdem läuft das ohne Probleme und ohne dass ich mich je wieder drum gekümmert hätte.
    Überall wo ich mich per Google Talk anmelde (z. B. im Pre oder Google-Mail) hab ich auch meine ICQ-Verbindung.
    Völlig Plattform-unabhängig in jedem Messenger, im Pre oder Programm und völlig zuverlässig über jabber.no.


    Wenn ich jetzt suche, finde ich diese super-Anleitung leider nicht mehr, aber das hilft sicher auch:
    http://www.cithrix.de/2010/08/…nsport-auf-android-handy/ (mit Server Liste!)
    http://www.bigblueball.com/for…e-talk-aim-msn-yahoo.html
    http://blogoscoped.com/archive/2006-05-02-n79.html


    Das halte ich auf jeden Fall für sehr viel sinnvoller und intelligenter als in jedem Gerät einzeln
    so ne dämliche ICQ- oder Sonstwas-Unterstützung dazu zu basteln bzw. dazu zu patchen. :D


    Nachteil: In den Pre-Kontakten erscheinen dann alle ICQ-Buddys zusätzlich als 2342345@icq.jabber.no, oder so.

  • Schau mal in dem Originalthread auf Precentral nach. Ich hatte ähnliche Probleme und Greg hat dort erklärt, welche Dateien er patcht, die man dann mit dem WebOS-Repair-Utility wieder restaurieren kann.
    Hat bei mir prima funktioniert.


    Ich habe das jetzt das wiederherstellen der einzelnen Datei mit dem ReapairUtility versucht und bei mir wird die Fehlermeldung eher schlimmer als besser. Ich kann leider auch nicht so viel damit anfangen. Sprich mir will sich nicht erschließen was da schief geht.


    Ist also immer noch der gleiche Stand, der Patch lässt sich nicht installieren, der AccounthinzufügenScreen zeigt nicht den OriginalBildschirm und wenn ich trotzdem versuche einen Account einzurichten funktioniert dieser nicht (Server nicht erreichbar).

  • Preware bietet da Lösungsansätze, die mir auch schon behilflich waren, unter der Kategorie Linux Application. Dort gibt es z.B. den Emergency Patch Installer "to reinstall all patch package data after a full or partial erease." oder Emergency Patch Recovery "...to restore all backed up files from any patch ipk installations.", was natürlich alle Patche entfernt und "grundrein" macht. Emergency File Verification "Verifies all patch packages are installed..." wäre natürlich auch denkbar.


    Der Emergency File Verification lässt sich aus Preware nicht installieren. Gibts ne echt lange Fehlermeldung.
    sowa mit -1: Unable run command . . ..


    Den EPR auszuführen habe ich son bisschen Sorge, dass ich dann nicht nur einen Patch habe der nicht mehr geht sondern gleich mehrere :)
    BIn aber kurz davor weil die genaueren Eingriffe bei mir nicht zu funktionieren scheinen.

  • Leute ... ich weiß nicht, was ihr da rumfrickelt ...


    Ich hab schon vor über einem Jahr einen Trasport von ICQ über jabber.no nach Google Talk eingerichtet und seitdem funktioniert ICQ einwandfrei ohne jedes Extra-Programm und ohne jeden Patch.


    Ich weiß ja nicht was der TRansport alles kann aber es geht ja nicht nur um ICQ.
    Es soll yahoo, icq, msn zusätzlich gehen. Zumindest bei mir. Der Patch ermöglicht ja noch reichlich mehr Protokolle auszuführen.

  • Der Patch lässt sich nicht installieren weil er immer sagt er wäre schon installiert und wenn ich die betreffenden Dateien wieder aus dem Original herstelle:


    listview-assistant.js
    messaging-constants.js
    messaging-luna-service.js


    Dann juckt das den Patch herzlich wenig. Er meckert die weiter als bereits gepatched an.


    Dann nochmal etwas genauer.
    Schau mal hier.


    Es sind 7 Dateien, die der Patch verändert. Alle müssen mit dem Repair-Utility wieder hergestellt werden.

    Besucht die PUG-Hamburg. Lockerer Stammtisch jeden zweiten Mittwoch im Monat. ALLE Smartphone-Systeme (webOS, PalmOS, Android, iOS, Blackberry, WP7, WinMob, Symbian, Maemo, Meego, Openmoko, Bada, u.a.) willkommen. http://www.amile.de/pug

  • Es sind 7 Dateien, die der Patch verändert. Alle müssen mit dem Repair-Utility wieder hergestellt werden.


    Ja ich habe mich da ewig durchgelesen und letztendlich dann die folgenden Dateien erfolglos getauscht.

    Code
    /usr/palm/applications/com.palm.app.messaging/app/models/messaging-constants.js
    /usr/palm/applications/com.palm.app.messaging/app/models/messaging-luna-service.js
    /usr/palm/applications/com.palm.app.messaging/app/views/prefsSetupAccount/prefsSetupAccount-scene.html
    /usr/palm/applications/com.palm.app.messaging/app/controllers/prefsAccountTypeList-assistant.js
    /usr/palm/applications/com.palm.app.messaging/app/controllers/prefsSetupAccount-assistant.js
    /usr/palm/applications/com.palm.app.messaging/app/controllers/compose-assistant.js
    /usr/palm/applications/com.palm.app.messaging/app/controllers/prefsAccountSummary-assistant.js
    /usr/palm/applications/com.palm.app.messaging/app/controllers/listview-assistant.js
    /usr/palm/applications/com.palm.app.messaging/app/views/prefsAccountSummary/prefsAccountSummary-scene.html


    Also nicht das ich sie nicht getauscht bekommen hätte, sondern erfolglos deswegen weil immer noch der AccountHinzufügenDialog nen leeren Button und einen für ICQ zu viel hat (die im Standard da nicht hingehören) und ich den messagingpatch nicht installieren kann.
    Fehlermeldung letzter Stand, siehe Screenshot oben.


    Immer artig Neustart nach dem erneuern der Dateien habe ich gemacht.
    Bin etwas ratlos und würde schon ganz gerne wieder nen Chatprogramm haben ;)

  • Such dir einen Anbieter aus, der alles unterstützt was du brauchst. ;)


    Hier ist eine umfangreiche Liste (inkl. uptime):
    http://www.jabberes.org/servers/


    Ja danke für die Liste. Ich glaube ich hatte das anfänglich schon mal versucht. Muss man dann nicht auch zu jedem Kontakt eine neue Authentifizierung durchführen. Die kennen ja nur meine ICQ oder YAHOO ID oder so. Oder bleibt das für die anderen gleich und transparent?

  • Ich glaube du musst die anderen Kontakte (erneut) bestätigen, aber für dein Gegenüber ändert sich nichts.


    Das geht ja dann vermutlich auf dem Pre gar nicht oder?
    Na sollte ich jemals meinen Messanger wieder ans Laufen bekommen, kann ich es ja auch mal damit versuchen.
    Außer einem Haufen Chaos im Adressbuch dürfte es ja keine Problem geben.


  • Wenn du diese Dateien ausgetauscht hast, sollten nur noch die Standardkonten in der Übersicht zu sehen sein und der Patch ist vollständig entfernt.
    Klappt das nicht, so wurden die Dateien nicht vollständig ersetzt. Gab es Fehlermeldungen vom Repair-Utility?


    Hast du noch weitere Patches installiert, die den Messenger betreffen? Wenn ja, die auch deinstallieren und nochmal alle Dateien austauschen.

    Besucht die PUG-Hamburg. Lockerer Stammtisch jeden zweiten Mittwoch im Monat. ALLE Smartphone-Systeme (webOS, PalmOS, Android, iOS, Blackberry, WP7, WinMob, Symbian, Maemo, Meego, Openmoko, Bada, u.a.) willkommen. http://www.amile.de/pug

  • Hast du noch weitere Patches installiert, die den Messenger betreffen? Wenn ja, die auch deinstallieren und nochmal alle Dateien austauschen.


    Stimmt ich habe noch nen Patch zum Messanger gefunden. Set Avatar in Messaging. Ich kann den aber nicht entfernen. Die Meldung heißt:


    Code
    Error: An error eccoured while attempting to run /tmp/ipkgScript.sh
    
    
    Unreversed Patch detected! Ignore -R? [n]


    Lässt das darauf schließen, dass man den Patch irgendwie doch wegbekommen würde, wenn man wüsste wie?


  • Stimmt ich habe noch nen Patch zum Messanger gefunden. Set Avatar in Messaging. Ich kann den aber nicht entfernen. Die Meldung heißt:


    Code
    Error: An error eccoured while attempting to run /tmp/ipkgScript.sh
    
    
    Unreversed Patch detected! Ignore -R? [n]


    Lässt das darauf schließen, dass man den Patch irgendwie doch wegbekommen würde, wenn man wüsste wie?


    Kontaktiere den Programmierer von diesem Patch oder durchsuche den Thread (sofern er existiert) bei Precentral.
    Wenn du weißt, welche Dateien betroffen sind, diese mit dem Repair Utility ersetzen.

    Besucht die PUG-Hamburg. Lockerer Stammtisch jeden zweiten Mittwoch im Monat. ALLE Smartphone-Systeme (webOS, PalmOS, Android, iOS, Blackberry, WP7, WinMob, Symbian, Maemo, Meego, Openmoko, Bada, u.a.) willkommen. http://www.amile.de/pug

  • Kontaktiere den Programmierer von diesem Patch oder durchsuche den Thread (sofern er existiert) bei Precentral.
    Wenn du weißt, welche Dateien betroffen sind, diese mit dem Repair Utility ersetzen.


    Ja hätte ich auch selbst drauf kommen können :)
    Habe ich dann mal gemacht, ma sehen was kommt und ob das dann hilft.


    Dir erst mal vielen Dank für die Unterstützung.

  • Hi,
    hat hier jemand einen Pre 2? Kann man da jetzt direkt in der App ICQ auswählen wie bei vielen Beta "leaked" Screenshots zu sehen war? Würde mir gerne einen Pre2 kaufen, auf Skype könnt ich ja gerade so noch verzichten, aber ICQ wäre schon ein muss. Bin ganz neu in der WebOS Welt, habe mich da ein wenig reingelesen... aber überall steht nur was von Patches, aber ich denke mal das bezieht sich auf die leute ohne WebOS 2.0. Hoff ich doch mal..


    wäre schön, wenn hier jemand eine, hoffentlich positive, antwort hat ;) evtl. mit Screenshot



    danke & ein schönes Wochenende


  • Ja hätte ich auch selbst drauf kommen können :)
    Habe ich dann mal gemacht, ma sehen was kommt und ob das dann hilft.


    Dir erst mal vielen Dank für die Unterstützung.


    Gern geschehen. 8)

    Besucht die PUG-Hamburg. Lockerer Stammtisch jeden zweiten Mittwoch im Monat. ALLE Smartphone-Systeme (webOS, PalmOS, Android, iOS, Blackberry, WP7, WinMob, Symbian, Maemo, Meego, Openmoko, Bada, u.a.) willkommen. http://www.amile.de/pug

  • Habe jetzt mit dem EPR die ganzen Patches entfernt und immer noch ist Messaging kaputt. Auch der MessagingPatch lässt sich noch nicht neu installieren.
    Also ein Haufen Arbeit für das erneute Installieren aller Patches und noch immer kein Messanger der funktioniert.