Navit für den Pre?

  • Hallo wieder mal ...


    ich habe gerade wieder den Uberkernel installiert (man das fluppt wieder :thumbup: Wenn nur nicht die Abstürze wären :oh-je: ) und ein neues Profil mit Screenstate 500/1000 bei einem Compcache von 32 MB eingerichtet. Leider startet Navit noch immer nicht.
    Nächster Schritt: Alle relevanten Pakete deinstallieren, sicherheitshalber Neustart, alles wieder neu installiert. Navit startet immer noch nicht!!
    Also kann ich wohl Navit erstmal für mich vergessen ... ;(

  • Den fstab-Fix hattest Du aber damals durchgeführt., die Sache mit nojail war ja nur eine Umgehungslösung? Evtl. ist der entsprechende jail-Eintrag in der Datei /var/palm/data/jailusers doppelt falsch vorhanden, ging mir jetzt nach dem Update von terminus so... Kann man mit InternalzPro editieren, Zeilenumbruch des Editors auf Linux stellen.

  • Hallo Kunz,


    vielen Dank für deine Tipps. Ich habe in der angegebenen Datei den Navit-Eintrag gefunden und komplett gelöscht. Dann hab ich Navit neu installiert. Dann hab ichs gestartet, dann ist nix passiert. Dann hab ich den fstab-Fix installiert und neu gestartet, dann hab ich nach dem Neustart Navit gestartet, dann ist wieder nix passiert. Dann leg ich den Pre gefrustet zur Seite und dann .... PLING Navit ist da und fragt mich, ob ich das GPS zulassen will


    HURRAAAAA. Danke, danke, danke. Nach soviel dann's musste ja ja klappen :thumbup:

  • Ich habe hier auch nochmal zwei merkwürdiges Pänomene:
    1. immer wenn ich Navit starte, wird mein CPU Takt auf die üblichen 500 MHz meines Pre (Minus) getaktet. Verfolgen kann ich das ganz gut in Govnah, Mithilfe ich üblicherweise immer bei 600 MHz und in der /etc/event.d/compcahe eingetragenen 32768(32MB) fahre. Nach Beenden von Navit bleibt der Takt auch bei 500 MHz...
    2. Neuerdings werden die Ansagen von Richtungswechseln etc. leicht abgehackt angesagt, sprich der Anfang fehlt und statt "In Hundert Metern links abbiegen" kommt nur noch "..Metern links abbiegen" - das Timing für die Ansagen würde zu den Richtungswechseln wie gehabt passen, nur ist der Anfang der Ansagen eben nicht hörbar.


    Hat jemand Anregungen oder Ideen zur Behung meiner "Probleme"?

  • Hallo!


    Jetzt habe ich ein Karten-Problem mit Navit. Es handelt sich um die ganz aktuell über den Navit Planet Extractor geladenen Karten von Rümänien bzw. Ungarn. So sieht das auf dem Gerät aus:
    [Blocked Image: http://i774.photobucket.com/albums/yy24/ZehHa/photos-temp-1jpg-9.jpg]


    [Blocked Image: http://i774.photobucket.com/albums/yy24/ZehHa/photos-temp-1jpg-8.jpg]


    Wie man unschwer sieht, ist die Landschaftsstruktur teilweise nicht korrekt dargestellt, sondern einheitlich blau. Die Straßen scheinen korrekt dargestellt zu werden, soweit ich das sehen kann.


    Woran kann das liegen? Hat jemand eine Idee, was man dagegen tun kann? Oder fehlen da einfach entsprechende OSM-Daten? Kann ich mir für den Großraum Budapest eigentlich nicht so recht vorstellen.


    Grüße


    Carsten

  • ICH FINDE NAVIT NICHT IM APP CATALOG!!! Wo bekomm ich es her??

    Navit ist auch keine offizielle App. Findest Du als Homebrew über Preware. Aber Vorsicht: Ohne weitergehende Kenntnisse (oder Bereitschaft, sich diese durch Lesen des Wiki und/oder dieses Faden anzueigen) wirst Du Probleme bekommen. Falls Du es trotzdem versuchen willst: Hier fängt es an.

  • [edit]Geändert, funzt nicht so, wie ich gedacht hatte...[/edit]


    Unter dem folgenden Link kannst Du das IPK-Paket downloaden und auf Deinem Pre installieren, am einfachsten geht es aber mit Preware. Dafür müssen die Testing-Feeds entsprechend eingegeben bzw. konfiguriert sein.


    Aktuelles Navit-IPK für Pre


    Achtung, nur für Pre (ARM V7), nicht für Pixie (ARM V6)!


    Die einfachste Lösung Karten zu erhalten gibts hier: Navit Planet Extractor. Auf "Predefined Areas" klicken und die entsprechende Karte auswählen. Funktioniert aber nur am Desktop Compute, nicht auf dem mobilen webOS-Gerät. Der direkte Download auf das Gerät ist auch machbar, setzt aber Kenntnisse über Linux, den wget-Befehl und die Koordinaten der gewünschten Karten voraus; als unabdingbare Voraussetzung außerdem eine Linux-Terminal-App auf dem mobilen Gerät.


    Grüße


    Carsten


    Disclaimer: Kann für ein Funktionieren nicht garantieren. Beim Erscheinen neuerer Versionen ist Link zum IPK ungültig! Link führt auf Version 0.5.0.4446 vom 22.4.2011.

  • Wer aufmerksam Updates in Preware checked oder Pre|Central verfolgt, weiß es vielleicht schon, für alle anderen sei es hier noch mal gepostet: Es gibt ein Update für Navit, dass im Wesentlichen zwei große Neuerungen bringt. Zum Einen gibt es jetzt den Navit Maps Helper, mit dem die OSM-Karten direkt auf den Pre geladen werden können. Zum Anderen kann über die Option "Standardanwendungen" im Launcher auch eingestellt werden, dass beim Tippen auf die Adresse in der Kontakte-App gleich die Navigation dorthin mit Navit gestartet wird. Hierzu wird ebenfalls Navit Maps genutzt. Beides finde ich super nützlich! Und läuft auch auf dem PreMinus.


    Grüße


    Carsten

  • Hallo,


    wie ist den die URL der beiden feeds?


    Vielleicht hab ich die nicht, da bei mir Navi Maps Helper nicht angeboten wird. Das neueste Navit hab ich gestern installiert, aber auch bei Standardeinstellungen kann ich Navit bei Adressen nicht auswählen.


    Danke!


    Rüdiger

  • Hallo Rüdiger,


    steht hier:


    Target Device: ALL
    Name: webos-testing-all
    URL: http://ipkg.preware.org/feeds/webos-internals/testing/all

    Target Device: Pre/Pre+/Pre2/Veer/TouchPad/Pre3
    Name: webos-testing-armv7
    URL: http://ipkg.preware.org/feeds/webos-internals/testing/armv7


    Unter dem Link sind auch die Daten für Pixi bzw den Emulator.


    Wichtig - denn das war mein Fehler, ist beide feeds hinzuzufügen.


    Dann sollte auch der Navit Maps Helper erscheinen.


    Viel Erfolg


    Michael

    TouchPad 64gb mit WebOs 3.0.5
    HP Pre 3 mit WebOS 2.2.4
    Palm Pre 2 mit WebOS 2.2.4
    Treo 680 + 4GB SDHC

  • Bei mir ging es. Habe es gleich gestern installiert und eingerichtet.


    Das sind wirklich zwei tolle neue Funktionen!

    Meine Laufbahn: IIIx, m505, T|T1, T|T3, Xplore G18, Treo 650, Treo 680, Centro, Pre 1, 1 +, 2 und 3. Jetzt TP mit Android und Sony Xperia Ray und erstaunlich zufrieden!

  • Wer aufmerksam Updates in Preware checked oder Pre|Central verfolgt, weiß es vielleicht schon, für alle anderen sei es hier noch mal gepostet: Es gibt ein Update für Navit, dass im Wesentlichen zwei große Neuerungen bringt. Zum Einen gibt es jetzt den Navit Maps Helper, mit dem die OSM-Karten direkt auf den Pre geladen werden können. Zum Anderen kann über die Option "Standardanwendungen" im Launcher auch eingestellt werden, dass beim Tippen auf die Adresse in der Kontakte-App gleich die Navigation dorthin mit Navit gestartet wird. Hierzu wird ebenfalls Navit Maps genutzt. Beides finde ich super nützlich! Und läuft auch auf dem PreMinus.


    Grüße


    Carsten

    Danke Carsten, dann muss es ja nicht nochmal schreiben. Hier noch der Linz zum Precentral thread.
    http://forums.precentral.net/w…nager-launcher-navit.html
    Zu ergänzen wäre noch das es auch über "Just type" funktioniert. Einfach die Adresse eingeben und dann als Anwendung Navit auswählen.


    Ich habe inzwischen einige Infos ergänzt.
    Wenn euch was auffällt einfach dort Posten. Leider kommen die Naxave Hinweis malis auf neue Beträge nicht immer an.


    Gruß
    HaPe

  • Ich bin begeister! Über 'Just type' bzw. aus der Kontakte-App heraus kann man jetzt sogar zu Hausnummern, sofern in den OSM Maps vorhanden, navigieren! Total super und "mega" gute Arbeit vom Navit Team bzw. den webOS Portierern und Betreuern!