Tine 2.0 - die eigene Wolke

  • Ein Ping bringt nicht viel, es ist nur eine Abfrage, ob der angepngte Rechner überhaupt im Netzwerk vorhanden ist...


    versuche mal von dem anderen Laptop aus auf die Seite des ActiveSync zu kommen (http://192.168.xxx.xxx/Microsoft-Server-ActiveSync/)


    wenn das geht, ist zumindest die FW nicht schuld...

  • War wohl doch die Windows-Firewall, habe sie nochmals auf Werkseinstellungen zurückgesetzt und Apache die entsprechenden Rechte erteilt.
    Fein, jetzt läufts und der erste Sync mit tine hat auch funtkioniert.


    Vielen Dank für eure Hilfe


    Grüße
    KristianR

  • ::EDIT::
    hab gestern das gleiche gemacht wie heute - jedoch heute hat er es irgendwie genommen - jetzt gehts wieder...
    *wunder*wunder*
    :verwirrt::verwirrt::verwirrt::verwirrt::verwirrt::verwirrt:
    /::EDIT::



    irgendwie hab ich mir mein AS zerschossen...


    ich hab nur tine in einen Unterordner geschoben, die Verzeichnisse beim Redirect geändert, neustart - und geht nichts mehr


    also alles wieder rückgängig gemacht - und gehen tuts trotzdem nicht


    in der error-log steht nicht - in der access-log steht:


    xxx.xxx.xxx.xxx - domain.de/Username [30/Jan/2010:21:37:07 +0000] "GET /Microsoft-Server-ActiveSync HTTP/1.1" 200 1307 "-" "AMLAgent/1.0"


    in der Tinelog steht:


    Code
    2010-01-30T21:37:56+00:00 INFO (6): Tinebase_Core::setupLogger::374 logger initialized
    2010-01-30T21:37:56+00:00 INFO (6): Tinebase_Core::setupCache::388 cache enabled
    2010-01-30T21:37:56+00:00 DEBUG (7): Tinebase_Preference_Abstract::getValue::129 get user preference "timezone" for account id 0
    2010-01-30T21:37:56+00:00 INFO (6): Tinebase_Core::setupUserLocale::580 given localeString 'auto'
    2010-01-30T21:37:56+00:00 DEBUG (7): Tinebase_Translation::getLocale::177 given localeString 'auto'
    2010-01-30T21:37:56+00:00 DEBUG (7): Tinebase_Translation::getLocale::189 'en' is not supported, checking fallback
    2010-01-30T21:37:56+00:00 DEBUG (7): Tinebase_Translation::getLocale::212 selected locale: 'en'
    2010-01-30T21:37:56+00:00 DEBUG (7): Tinebase_Server_Http::handle::32 is http request. method: EMPTY
    2010-01-30T21:37:57+00:00 DEBUG (7): Tinebase_Config::getConfig::113 Config setting for redirectUrl not found, using default.
    2010-01-30T21:37:57+00:00 INFO (6): index.php (63) TIME: 0.63139796257 seconds 8.25 MBytes


    und nun??? was soll ich damit anfangen???


    achso: vhosts.conf

    Apache Configuration
    ALIAS /Microsoft-Server-ActiveSync /var/customers/webs/domain/tine/index.php
      Allow from all
      Options +FollowSymlinks
      RewriteEngine on
    RewriteLog "/var/customers/webs/domain/tine/rewrite.log"
    RewriteLogLevel 5
    #  RewriteBase /
      RewriteCond %{HTTP:Authorization} ^(.*)
      RewriteRule ^(.*) - [E=HTTP_AUTHORIZATION:%1]
      RewriteRule ^Microsoft-Server-ActiveSync(.*) /var/customers/webs/domain/tine/index.php$2 [E=ACTIVESYNC:true,E=REMOTE_USER:%{HTTP:Authorization}]


    das ActiveSync Test tool sagt mir:

    Code
    ActiveSync:
    	Checking for application ................. FAIL
    
    
    Result:
    	ActiveSync detected, but not correctly configured.
  • ich wollte mir nen wohl auch Tine2.0 installieren, aber wie genau synce ich da das Palm Pre mit ? gibt es da noch ein Programm auf dem Palm für, oder muss ich mit dem Palm nur auf die Seite gehen und dann geht das darüber ? fragen ober fragen, aber finde nirgends die antwort....

  • Der Pre unterstützt von Werk ab ActiveSync. Einfach ein neues Konto in Mail, Kontakte oder Kalender einrichten. Das wird dann automatisch übernommen. Mein Pre synct mit 2 EAS-Konten (Alice und Tine). Melde dich, wenn du noch Fragen hast.
    Jonas

  • Hat eigentlich schon jemand eine verschlüsselte Verbindung hinbekommen? Im Moment läuft das ja nicht über SSL...


    Kann ich bestätigen... läuft - zwar ist das Zertifikat nicht signiert - jedoch für den Privatbetrieb ist selbst das nicht signierte Zertifikat durchaus akzeptabel...

  • ich habe nun Tine auf meinem Webspace am laufen aber weiß noch nicht so ganz wie ich den pre einstellen muss....


    email adresse ist klar, aber beim posteingangsserver, muss ich die URL wo tine liegt angeben oder was genau das gleiche gilt für domäne ...

  • Bei der Adresse die URL, also http://<server_name>, bei der verwendung von https
    mußt du zuerst das cert abholen, mit deinem Browser (am Pre) auf https://<server_name>
    und dort dann das cert eintragen.


    Beim login den usernamen und Password eintragen, domain kann leer bleiben, email
    solltest du noch eintragen.


    Das ganze geht natürlich nur wenn http(s)://<server_name>/Microsoft-Server-ActiveSync
    wie weiter oben beschrieben auf index.php zeigt.

  • Und dann ;) Login name eingeben und Password, dann sollte ein
    It works!
    Your username is: <login> and your IP address is: <deine IP>
    erscheinen


    habs grad nochmal probiert, auch wenn ich das unter Mail
    einrichte, neues Konto, Manuell und dann eben obige Daten
    eingebe klappt das auch mit fiktiver Mailadresse.


    Ich kann mich aber erinnern das ich so eine Meldung auch
    hatte, ich denke als das ActiveSync nicht richtig lief.

  • Wenn ich deine Adresse oben aufrufe bekomme ich das Tine20 Login (Weblogin),
    das ist Falsch. Du solltest dann ein http Login Fenster von deinem Browser bekommen.
    Das gleiche wie wenn du mit .htaccess eine Zugangskontrolle festlegst.


    Oder bekommst du nach erfolgtem Login das "It works!" im Browser angezeigt?


    Ich sage es nochmal, dein Fehler leigt vermutlich im RewriteRule, in meiner obigen
    Beschreibung habe ich das bei der Konfig so definiert

    Apache Configuration
    # Alias für Tine20 ActiveSync
    Alias /Microsoft-Server-ActiveSync c:\xampp\htdocs\tine20\index.php
    
    
    RewriteEngine on
    RewriteRule /Microsoft-Server-ActiveSync(.*) /tine20/index.php$1 [E=REDIRECT_ACTIVESYNC:true,E=REMOTE_USER:%{HTTP:Authorization}]


    Und das alles in der httpd config des Apache.


    wie du das bei deinem Webspace (Provider) einichten mußt weiß ich leider nicht, obiges
    läuft zur Zeit bei mir auch nur in der XAMPP Install unter Windows.

  • hab auch gestern mit meinem hoster geredet (mit dem ich das auch versucht habe einzurichten) er meinte ist bei ihm ohne große umbauten leider nicht machbar :( naja nun mal gucken weil zuhause hosten hab ich nicht viel lust dran