webOS 2.1 für Europa - Pre Plus (Meta für Pre Minus)

  • Gibt es denn jetzt überhaupt unterschiedliche Update-Versionen?


    Ich sehe es eher so, dass das Update von gestern schon OK war, aber es Probleme (vielleicht Überlastung) beim Profil-Server gab.


    Hier gab es doch mehrere Rückmeldungen, dass das Profil nach ein paar Stunden dann doch auf dem upgadateten Pre+ fundktioniert hat!?

    Meine Laufbahn: IIIx, m505, T|T1, T|T3, Xplore G18, Treo 650, Treo 680, Centro, Pre 1, 1 +, 2 und 3. Jetzt TP mit Android und Sony Xperia Ray und erstaunlich zufrieden!

  • So, mein altes Profil spielt sich gerade zurück. Habe den Tip weiter oben ausprobiert: In meine, neuen "leeren" Profil über "alle Anwendungen löschen" gegangen, dann meine "alte" Profil-Email-Adresse eingegeben und jetzt wird grad alles zurückgespielt. Danke allen Beteiligten für die schnelle Hilfe (O2, Palm, etc.pp.)!


    Hmhm. Geht auch nicht. Ich geh' jetzt noch mal zum ganz frischen MetaDoctor - vielleicht hab' ich ja auch zuviel verbastelt. Erfolgsmeldungen trotz Pre Minus gab's ja schon einige


    Edit: selbes Problem. 9.9.9, komme nicht in mein altes Profil - hmpf! Auf Precentral gibt's noch jemand mit dem Problem. Hat hier schon jemand erfolgreich sein altes Profil auf eine o2-Pre-minus mit einem anderen Provider wiederherstellen können?

  • Auf Precentral wurde ein Script veröffentlicht, mit dem man einen Sprint Pre flashen kann. Man müsste für o2 die Quellen der Doctoren ändern. Hat da jemand Ahnung? Kann jemand den in ein o2 Script verwandeln? Dieses Script wird anscheinen auch in den MetaDoctor aufgenommen.


    Dabei geht es aber darum, dass für Sprint Teile der Firmware ausgetauscht werden müssen - für o2 tut das ja nicht Not. Etwas einfacher macht das Script allerdings, das ist richtig.

  • Hallo,
    als glücklicher Besitzer einer Classic-Lizenz interessiert mich natürlich brennend, ob es mit dem Einfügen des gesicherten ROMs aus dem 1.4.5er Doctor in WebOs 2.1 klappt.
    Hat das schon jemand ausprobiert?


    Liebe Grüße Jutta

    :)PDA-History:
    Franklin Ebookman, SONY CLIE PEG-T625C, Treo 270, Treo 600 (Sprint/USA, nur als PDA genutzt). M28 von Xplore, Treo 650. Treo 680, Centro, Fossil Wrist PDA. Aktuell: Palm Pre und für unterwegs zum Arbeiten: Samsung NC10

  • muelleimer2k:


    Kannst Du denn SMS schreiben? Bei Precentral wird beklagt, dass das nicht möglich sei.


    Viele Grüße!

    Kann leider nicht testen ob ich paid apps installieren kann weil ich bisher keine gebraucht habe. Mein altes Profil wurde aber zurück gespielt mit allen Einstellungen. SMS geht. gerade ausprobiert.


    Aber meine Konverationen haben sich verabschiedet :)

  • So nun melde ich mich auch mal...




    Würd gern auch meinen Pre- auf das 2.1 Updaten mit nem Doc. ders kann...




    Fragen:




    -Mit Windows ist da nichts zu machen? Verstehe ich das richtig?!


    -Gibts die möglichkeit, dass jemand vll. ein HowTo erstell wie was gemacht werden muss (natürlich ohne jegliche Rechte zu verletzen)?
    Mit allem was dazu gehört...vorbereitung des aktuellen 1.4.5 Pre's bis zum Testen verschiedener Funktionen ob alles geklappt hat. :)


    -Wie siehts mit dem Pixi (plus) aus? Gibts da schon was?


    -Wie kann ich jemandem was gutes tun indem er so ein HowTo erstellt und die auch preisgibt. (kenne mich ziemlich gut bei Autos aus Mercedes als favorit!




    Vielen Dank




    Grüße

  • Im Moment würde ich aber behaupten: beim Pre Minus kommt es teilweise noch zu Problemen. Mein 9.9.9 habe ich noch nicht wegbekommen, bei anderen klappt's auf Anhieb, steht auf Precentral. Sehr seltsam.

  • Doch über Windows gibts die Möglichkeit mit cygwin... Aber eigentlich ist es einfacher wenn man ne Ubuntu live CD nimmt.


    Das Pixi hat nen anderen Prozessor --> Keine Mögichkeit für 2.1 im Moment.

    HOWTO: WebOS 2.1 für das Pre-:


    WICHTIG!!!! DER GANZE FOLGENDE VORANG WIRD AUF EIGENE GEFAHR DURCHGEFÜHRT !!!! ICH ÜBERNEHME KEINE VERANTWORTUNG FÜR GERÄTE UND DATEN DIE BEI DIESEM VORGANG BESCHÄDIGT ODER ZERSTÖRT WERDEN!!!!


    Im Vorfeld empfehle ch via Save/Restor ein Backup zu machen. Habe leider meine kompletten SMS verloren :)


    Okay hier wie ich es gemacht habe:


    1. Ubuntu gestartet, Alternativ kann man auch einfach Ubuntu via live CD Starten. ist bei allen Dists dabei. CD/USB rein und auf Live CD bzw. glaub das heißt irgendwas mit testen...
    2. In Ubuntu muss man jetzt die Konsole öffnen. --> Anwendung --> Zubehör --> Terminal
    3. Jetzt gehts los mit einigen Befehlen:


    - sudo apt-get install git-core
    - git clone git://git.webos-internals.org/tools/meta-doctor.git
    - sudo apt-get install patch
    - Jetzt muss Java installiert werden. Geht am einfachsten mit dem OpenJDK Java 6 welches man direkt über das Softwarecenter installieren kann.
    - Die Novacom Treiber fehlen noch. Diese müssen von: http://developer.palm.com/inde…tent&view=article&id=1585 geladen und installiert werden. Bite auf die Architektur achten!
    - cd ./meta-doctor (Einfach meta eingeben und dann Tab drücken. Sollte sich vervollständigen und dann weißte auch dass du richtig bist
    - mkdir downloads
    - cd ./downloads
    - wget http://palm.cdnetworks.net/rom…bosdoctorp101ueude-wr.jar
    - mv webosdoctorp101ueude-wr.jar webosdoctorp101ueude-wr-2.1.0.jar
    - cd ..


    Wichtig: die nächsten Schritte gelten in der Form nur für das deutsche Pre- bzw. die GSM Variante.
    - make DEVICE=preplus CARRIER=wr REMOVE_MODEL_CHECK=1 clobber all


    Jetzt sollte der PC erst mal 3-5 Minuten Arbeiten und danach wieder eine leere Befehlszeile anzeigen. Wichtig: Schaut ob das Textgekröse mit Fehlern beendet wurde. Falls nicht: Gratuliere nur noch ein kurzes Stück bis WebOS 2.1 auf dem pre-


    Jetzt öffnet ihr --> Persönlicher Ordner --> meta-doctor --> Build --> preplus-p101ueude-wr-2.1.0


    Hier sollte nun die webosdoctorp101ueude-wr-2.1.0.jar angezeigt werden.


    Für Ubutu: Da Ubuntu immer wegen dem executable bit rumnölt: Rechtsklick auf die Datei --> Eigenschaften --> Zugriffsrechte --> Haken bei Programm als Datei ausführen. --> Schließen


    Jetzt Rechtsklick: Mit Java ausführen. Und der Webos doc startet.


    Jetzt einfach wie einen normalen WebOS doctor handhaben und das Gerät flashen.


    Sollte alles klappen: Viel Spaß mit webos 2.1 auf dem pre-



    Für Verbesserungen oder falls ihr Fehler gefundden habt: Zitiert einfach und verbessert oder schreibt mich an. Sollte jemand das ganze gut finden darf er es gerne weiter posten ;)
    Das meiste hab ich vom WebOS-Internals-Wiki und nur geringfügig angepasst. Hier das Original http://www.webos-internals.org/wiki/Application:MetaDoctor


    Gruß
    Muelleimer2k


  • Wichtig: die nächsten Schritte gelten in der Form nur für das deutsche Pre-
    - make DEVICE=preplus CARRIER=wr REMOVE_MODEL_CHECK=1 REMOVE_CARRIER_CHECK=1 clobber all


    Warum REMOVE_CARRIER_CHECK=1? Im Makefile steht, dass das zu Problemen mit dem dem App-Catalog führen kann. Der "Carrier" für uns ist ja world-ready, oder? Den düften alle Pres in .de schon vorher gehabt haben. Kannst Du das erklären? Ich hab's allerdings nicht benutzt und bei mir funktioniert es auch nicht ;)

  • Warum REMOVE_CARRIER_CHECK=1? Im Makefile steht, dass das zu Problemen mit dem dem App-Catalog führen kann. Der "Carrier" für uns ist ja world-ready, oder? Den düften alle Pres in .de schon vorher gehabt haben. Kannst Du das erklären? Ich hab's allerdings nicht benutzt und bei mir funktioniert es auch nicht ;)


    "REMOVE_CARRIER_CHECK=1" sollte bei deutschen Pres *nicht* genutzt werden.