Hotsync unter Linux

  • Hallo zusammen.


    Habe ein Problem mit meinem TX. Habe nach längeren versuchen es geschaft meinen Palm an Ubuntu 6.10 zu hängen. HotSync klappt endlich mit KPilot. Habe auch die aktuellste Version 3.5.6 installiert


    Nur nun trägt er mir die Termine 3-4 fach ein und teilweise durcheinander.
    Kennt jemand das Problem


    Viele Grüße
    Flar

  • Hallo,
    ich "betreibe" meinen m 105 unter SuSE 10.2 am com1 mit kpilot, als PIM verwende ich Kontact. Das funktioniert soweit recht ordentlich, nur - die vom PC auf den Palm übertragenen Daten (nach dem HotSync-Protokoll hat eine datenübertagung stattgefunden) sind dort nicht sichtbar! Die Programm-Installation funktioniert problemlos, ebenso die Übergabe von Adressen, Terminen usw. an Kontact.
    Kann mir da jemand weiterhelfen?

  • Quote

    Original von eckimoewe
    nur - die vom PC auf den Palm übertragenen Daten (nach dem HotSync-Protokoll hat eine datenübertagung stattgefunden) sind dort nicht sichtbar! Die Programm-Installation funktioniert problemlos, ebenso die Übergabe von Adressen, Terminen usw. an Kontact.


    moment... programme werden installiert, adressen, termine und kontakte klappen auch... welche "daten" kommen denn nicht auf dem Palm an?

  • Hallo,


    wenn ich das richtig verstehe klappt die Synchronisation der Adressen nur in die Richtung Palm->PC, nicht aber umgekehrt.


    Ist in den Einstellungen der Syncsoftware auch synchronisieren eingestellt, oder vielleicht Palm überschreibt PC?


    Gruesse,


    Toem

  • Also, das Installieren von Programmen vom PC auf den Palm funktioniert; auch die Übertragung der Daten (Adressen, Termine usw.) vom Palm auf den PC. Umgekehrt klappt's leider nicht. Kpilot ist eigentlich so eingestellt, dass die beidseitige Synchronisation stattfinden müßte.

  • Hi.


    Probier mal mit jpilot. Wenn das funktioniert (syncen in beide Richtungen, Installationen, usw.) dann liegts wahrscheinlich an kpilot.


    Unter debian und kde hatte ich ein ähnliches Problem. Bin dann auf jpilot umgestiegen und seit dem kein Stress mehr.


    Allerdings ist jpilot ein eigenständiges Programm und somit nicht in kontact zu integrieren. Vielleicht kann man noch von kmail auf die Adressen zugreifen, bin mir da aber nicht 100% sicher.



    Gruß

  • Welche KDE-Version ist in Deiner Suse? Alles < 3.5.6 macht diverse Problemchen, die dann wohl behoben wurden.


    Nein ich setze kein KDE ein. Bin auch mit der JPilot-Lösung zufrieden. Dazu noch Sylpheed oder Claws-Mail (beide kommen mit Jpilot-Adressbüchern klar) als Mailer und die Welt ist in Ordnung


    Rainer

  • Hallo,


    ich habe einige Zeit lang den Laufwerksmodus meines Lifedrive unter Linux genutzt.
    Leide wird es jetzt nicht mehr automatisch gemountet. Manuelles mounten funktioniert,
    also liegt der Fehler wohl in Hotplug, HAL, usw. Vermutlich fehlt nurdir richtige Konfiguration
    in /etc/hal.d oder so. Kennt sich damit jemand aus?


    Aktuelles System: SuSE 10.3, also Kernel 2.6.22.5 benutze KDE.


    Danke,
    Bernd.

  • Meinen Treo 680 synce ich mit Ubuntu 8.04.1 (gnome-pilot und Evolution, über USB).


    Dennoch habe ich einige Probleme, die ich nicht in den Griff bekomme:
    - Kategorien werden nicht richtig gesynct (anscheinend soll eine Kategorie reichen :thumbdown: )
    - Gebe ich unter Evolution z.B. nur eine private Telefonnummer ein, so erscheint dieser Eintrag stets doppelt ;( (auch auf dem Treo).
    - Man kann anscheinend immer nur eine Kategorie syncen (bei Adressen). Zumindest kann man es in den Conduit-Einstellungen
    nur so eingeben ... :oh-nein:
    - und wie kann ich Anwendungen installieren?


    Was soll ich nun tun? Auf jpilot umsteigen? Oder mich von Evolution abwenden? eMails will ich nicht syncen.
    Ich freue mich auf Euere Vorschläge!
    Danke!


    Ciao
    PDAFan

  • So dann kommen hier mal meine Erfahrungen mit Palm und Linux:
    -Debian Etch (stable)
    -Palm Tungsten T3
    Version: KPilot 4.9.0 (depth9)
    Version: pilot-link 0.12.1
    Version: KDE 3.5.5
    (alles wie bei etch dabei):


    erster Kontakt (des T3)mit Linux:
    T3 (über USB) anstöpseln dabei folgenden Befehl in einer shell/Terminal starten:
    tail -f /var/log/syslog
    -dann Hotsync Butten betätigen
    -in der shell erscheinen dann ein paar Meldungen, die auch zeigen an welchem device der Palm hängt (meist /dev/ttyUSB0 und/oder /dev/ttyUSB1)


    falls nicht, brauchts noch (als root) ein:
    modprobe visor
    (als bootstabile Lösung muss es dann in /etc/modules eingetragen werden)


    für den ersten Kontakt braucht es dann noch eine ID und namen für den Palm:
    install-user -p /dev/ttyUSB1 -u <name> -i <5-stellige ID>


    dann /dev/ttyUSB1 bei KPilot als 'Pilot device' eintragen.


    KPilot starten, Palm anklemmen, HotSync starten, fertig.


    Was nicht geht:
    -restore Funktion (falls der Pilot mal alles vergessen hat: nicht restore benutzen, sondern HotSync mit PC overwrites Handheld)
    -Kategorien werden nicht übertragen, wenn sie im KOrganizer eingetragen wurden, ordnet man sie auf dem Palm zu Klappts
    --> WICHTIG: von Hand dafür sorgen, daß die Kategorien auf beiden Seiten gleich sind.


    So jetzt mache ich mich daran ein bischen mit neueren Versionen zu testen (Sidux)

  • Habe ein wenig weiter getestet:
    -Debian LennyBeta2 mit
    -Kpilot 4.9.4-3510 (elsewhere)


    Bisher nur der Kalender getestet.
    Kategorien müssen auf PC und Handheld einzeln angelegt werden


    T3:
    beide Richtungen syncen einwandfrei


    Abacus mit DateBkCat:
    -beide Richtungen syncen inkl.Kategorien, leider beibt der sync auf dem Abacus immer hängen (nach soft reset alles i.O.)
    - DateBkCat ist ein extra Anwendung, was bedeutet ich kann Kategorien oder den Kalender ansehen.


    Abacus mit DateBk6:
    beide Richtungen syncen inkl. Kategorien


    offen:
    -Adressen, todo,

  • Noch eine "simply works" Geschichte:


    System: openSUSE 11 mit Gnome 2.22. Ein unterstützter Bluetooth-USB-Adapter ist eingebaut. Gnome Bluetooth Icon ist im Systemtray sichtbar. Hier Rechtsklick, "Einstellungen": "Adapter ist für andere Geräte sichtbar" einstellen. Den Adapternamen kann man hier auch einstellen, aber das funktionierte nicht, der PC hiess weiterhin "BlueZ(none)(0)". Das ist aber nur ein Schönheitsfehler...
    In Evolution: "Synchronisationsoptionen...", darin als Gerät nur "Bluetooth ausgewählt, sonst nur weiter. Das heisst, "dieses Gerät hat schon mal gesynct" ausgewählt lassen. Ist das nicht der Fall, kann man selber Namen und ID eingeben, aber das habe ich nicht getestet. Dann wartet der Assistent auf einen Hotsync...
    Am Centro: Den "Bluetooth-Synchronisation" Assistenten ausführen, meinen PC gesucht, gefunden und ausgewählt, sonst nur weiter. Dann einen Hotsync mit "BlueZ..." gestartet und Evolution hat die Daten empfangen.
    Danach kann man das Gerät benennen und findet es in ener Liste in den Synchronisationsoptionen wieder. Wennman hier "Bearbeiten" für das Gerät wählt, kann man Conduits konfigurieren. Da habe ich Backup, Adressen, Kalender, ToDo und Memos aktiviert, sowie einen Zeitabgleich. Es gibt noch weitere Conduits (Expense, Mail), die ich aber nicht getestet habe. Bei Adressen etc. kann man als "initiale Aktion" "Vom PDA kopieren" auswählen, dann geht man sicher, dass die Centro Datenbanken Priorität haben werden.
    Danach am Centro den Bluetooth-Hotsync starten, der dauerte ziemlich lange aber es lief alles fehlerfrei durch.


    Ich hoffe, dieser Bericht ermutigt euch, das auch mal zu versuchen. Viel Glück!

  • hallo Clemens,


    dank deiner Anleitung ist es mir auch endlich gelungen meinen T3 mit Kubuntu 8.10 zu syncronisieren.
    Lediglich die Mails landen nicht auf dem T3. Dort ist ja Versamail installiert. Evolution empfängt meine Mails ohne Probleme, (Googlemail IMAP).
    Ich finde auch kein Conduit unter Evolution, um die Mails mit dem T3 abzugleichen.


    Hast du da noch einen Tipp ?
    Oder geht es einfach nicht ?


    danke
    Palm-Fan

  • hallo Clemens, dank deiner Anleitung ist es mir auch endlich gelungen meinen T3 mit Kubuntu 8.10 zu syncronisieren.


    Das ist ja schoen. Ich freue mich, dass die Anleitung fuer jemanden sinnvoll war und auch geholfen hat :)


    Lediglich die Mails landen nicht auf dem T3. Dort ist ja Versamail installiert. Evolution empfängt meine Mails ohne Probleme, (Googlemail IMAP). Ich finde auch kein Conduit unter Evolution, um die Mails mit dem T3 abzugleichen. Hast du da noch einen Tipp ? Oder geht es einfach nicht ?


    Da ich meine Mails prinzipiell mit dem Treo OTA abrufe, was ja schneller ist, als sie erst mit einem Desktop zu synchronisieren, hatte ich dieses Problem noch nie. Ich weiss leider (im Moment) auch keine Loesung dafuer. Sollte mir etwas begegnen, lass ich es Dich wissen.