Navit für den Pre?

      HansPeter, Danke für den Hinweis zu den Konfigurationsdateien. Da hätte ich auch selbst drauf kommen können. Ich werde auch mal versuchen, in <navigation> die Gewichtung der Strassentypen für die Routenberechnung zu ändern. - Gerade gemerkt, das sind doch nur die Announce-Distanzen. - Die Klassifizierung in OSM ist ja offenbar doch nicht so einheitlich,so dass öfter merkwürdige Umwege berechnet werden.
      Zum GPS : Ich hatte den Eindruck dass eben nicht R= unendlich angezegt wird, wenn kein GPS-Signal , sondern erst dann wieder aktualisiert wird, wenn eine gültige Position da ist. Vielleicht kann man auch einen Grenzwert für R setzen...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Kunz“ ()

      Kunz schrieb:

      Zum GPS : Ich hatte den Eindruck dass eben nicht R= unendlich angezegt wird, wenn kein GPS-Signal , sondern erst dann wieder aktualisiert wird, wenn eine gültige Position da ist. Vielleicht kann man auch einen Grenzwert für R setzen...


      Ich würde sagen, alles, was über 30m Genauigkeit geht, ist Google - die Anzeige wird bei mir auch sauber aktualisiert (im Büro, am Fenster, machmal hab' ich GPS, manchmal nicht)

      Kunz schrieb:

      Zum GPS : Ich hatte den Eindruck dass eben nicht R= unendlich angezegt wird, wenn kein GPS-Signal , sondern erst dann wieder aktualisiert wird, wenn eine gültige Position da ist. Vielleicht kann man auch einen Grenzwert für R setzen...
      Ja den Effekt/Eindruck habe ich auch. Deshalb der Verweis auf Minimap. Das verhält sich leider genauso, Sprich die Anzeige hängt bis die nächsten GPS/Google Daten kommen an dem Punkt und mit der Genauigkeit des letzten Signals.
      Da Minimap ja eine ja rein HTML/Javascript ist und die Offizielle GPS API benutzt ziehe ich es als Vergleich zum Tetsen ran ob das Problem bei Navit oder am Pre/Webos liegt.

      Aus dem Grund auch der Geanke das sich jemand mal die OSD Konfig ansehen kann. Dort giebt es Elemente für die Anzeige der Signalstärke. Ob ie dabe beim Pre funktioniren und ob alle benötigten Grafiken da sind. Keine ahnung. Ich hab leider momentabn nicht die Zeit mich da im Detail drum zu kümmern.

      HaPe
      Habe Navit heute gleich mal mit meinem neuen Führerschein getestet! 8o
      Ich hatte weder Abstürze noch sonst irgendwelche Probleme. Bei TomTom kann man sich eigene Sprachpakete erstellen. Das muss doch bei Navit bestimmt auch gehen oder? Ich finde, dass das Englisch von Navit so robotermäßig klingt.
      Jonas
      TamsPalm Deutschland - Aktuelles, News und Testberichte rund um webOS & Android.

      /// Infos, Anleitungen und Videos zu Homebrew///


      Heute nachmittag lief die Anzeige von Navit ganz normal. Ich habe jetzt eine neue Hypothese dazu. Das GPS des Pre ist ja standardmäßig auf aGPS verkrüppelt, obwohl der Qualcomm-Chip auch autonomes GPS könnte. Vielleicht hatte Eplus oder aber der Anbieter, der die Almanachdaten den Mobilfunkbetreibern bereitstellt, irgendeine Störung. Wenn die Almanachdaten nicht richtig aktuell sind, läuft die Ortsberechnung nicht so richtig...(ist eine iterative Berechnung und läuft sich vielleicht tot). Das würde erklären, dass es bei allen "hing".
      Ich hatte schon mit QPST und QXDM versucht, das Vorgehen aus dem Precentral-Thread nachzuvollziehen, um auch autonomes GPS zu ermöglichen, aber offenbar geht das auf dem GSM-Pre nicht. Wenn jemand hier weiterkommt, bitte mal posten.

      QXDM über USB-Passthrough am Pre ist leider das einzige Tool, dass Satellitennummern und Feldstärken des GPS im Klartext anzeigt, der Pre selbst liefert ja nur diese Genauigkeit R.


      Ich hatte jetzt endlich auch eine Sprachausgabe, bei mir war einfach die Edienlautstärke runtergedreht. Die Aussprache von "Strasse" klingt ja echt merkwürdig...

      Jonny-TX schrieb:

      Bei TomTom kann man sich eigene Sprachpakete erstellen. Das muss doch bei Navit bestimmt auch gehen oder? Ich finde, dass das Englisch von Navit so robotermäßig klingt.
      Jonas
      Hi Jonas,

      die Sprachausgabe erfolgt bei Navit nicht über zusammen gestückelte Wave Dateien sondern über eine Sprachsynthese => de.wikipedia.org/wiki/Sprachsynthese
      Deshalb kann Navit die Straßenname Vorlesen. dafür wird espeak verwendet und deshalb klingt das ganze auch so roboterhaft. Du kannst über Parameter die Stimme zwar etwas beeinflussen, es wird aber nie die Gualität einer Wave ausgabe von TomTom erreichen.

      Bei mir spricht Navit inzwischen auch Deutsch. Leider ist das nicht ganz so simple anzupassen. Mal sehen ob ich bald ein neues Paket mit deutscher Sprachausgabe zusammenstellen kann. Ich weis im Moment nicht wann ich die Zeit dazu finde.

      Gruß
      HaPe
      Erst mal.... Vielen Dank @ Hanspeter für den Einsatz. Ein onboard Navi fehlt mir ganz besonders am Pre. Das ganze macht zwar einen sehr provisorischen Eindruck, bin aber echt dankbar hier einen ersten Ansatz zu finden.

      Was mir nicht so ganz klar ist, warum nicht alle Strassen, die in der Karte angezeigt werden, nicht auch in den Strassennamen aufgelistet werden. (z.B. Düsseldorf - am Gartenkamp).

      Bin gespannt wie sich das Prog. noch so entwickelt.

      Kunz schrieb:

      Ich habe jetzt eine neue Hypothese dazu. Das GPS des Pre ist ja standardmäßig auf aGPS verkrüppelt, obwohl der Qualcomm-Chip auch autonomes GPS könnte. Vielleicht hatte Eplus oder aber der Anbieter, der die Almanachdaten den Mobilfunkbetreibern bereitstellt, irgendeine Störung. Wenn die Almanachdaten nicht richtig aktuell sind, läuft die Ortsberechnung nicht so richtig...(ist eine iterative Berechnung und läuft sich vielleicht tot). Das würde erklären, dass es bei allen "hing".


      Ich hab das System hinter aGPS anders verstanden. Der Netzanbieter liefert ungefähre Positionsangaben und zusätzlich Infos zu den aktuell in Reichweite befindlichen GPS-Satelitten.
      Mit diesen Infos ist der Pre in der Lage schneller einen Sat-Fix zu erreichen. Reine GPS-Empfänger ohne a müssen diese Infos aus den Sat-Signalen entschlüsseln und das dauert länger.

      Die eigentliche Genauigkeit des Systems ist nur von der Empfangsqualität des eingebauten Empfängers abhängig, aGPS verbessert oder verschlechtert da nix.

      Leider kann der Pre im Standard ohne Mobilfunknetz keinen Fix erreichen, da er die Oben genannten Sat-Signale nicht auswertet. Hat der Pre aber seinen Fix, hält er ihn auch ohne Netzempfang.

      Palmiga schrieb:

      Ich hab das System hinter aGPS anders verstanden. Der Netzanbieter liefert ungefähre Positionsangaben und zusätzlich Infos zu den aktuell in Reichweite befindlichen GPS-Satelitten.
      Mit diesen Infos ist der Pre in der Lage schneller einen Sat-Fix zu erreichen. Reine GPS-Empfänger ohne a müssen diese Infos aus den Sat-Signalen entschlüsseln und das dauert länger.
      Das ist genau so. Hast Du also richtig verstanden.
      Es heisst ja auch nicht umsonst assisted GPS. Es soll eben nur dem eigentlichen GPS-Empaenger dienlich sein. AGPS alleine bringt gar nichts, wird aber gerne mit anderen gutklingenden Worthuelsen durcheinander gebracht...
      beste Gruesse
      Clemens

      Hanspeter schrieb:

      Bei mir spricht Navit inzwischen auch Deutsch. Leider ist das nicht ganz so simple anzupassen. Mal sehen ob ich bald ein neues Paket mit deutscher Sprachausgabe zusammenstellen kann. Ich weis im Moment nicht wann ich die Zeit dazu finde.

      Könntest du die entsprechenden Dateien mal hochladen? Wäre klasse! :rolleyes:
      TamsPalm Deutschland - Aktuelles, News und Testberichte rund um webOS & Android.

      /// Infos, Anleitungen und Videos zu Homebrew///


      Jonny-TX schrieb:

      Hier habe ich was interessantes gefunden: freeyourphone.de/portal_v1/viewtopic.php?f=22&t=407&start=45
      Aber wo kann ich das ändern?


      Wenn Du das hier meinst:

      export LANG=de_DE

      vorm starten in die konsole eingibt, muss man auch nicht immer erst das land auswählen, bevor man die stadt wählen kann. das lässt sich auch in die verknüpfung integrieren:


      dann kannst Du das in der navit.sh ändern. Ich dachte bisher aber, dass das LANG=C aus einem bestimmten Grund gesetzt wurde.

      shinebar schrieb:

      navit.sh

      Danke, aber wo finde ich die? Im Verzeichnis mit der Navit.xml ist die nicht drin.
      Ah, die ist im cryptofs-Verzeichnis. Habe sie glatt übersehen :)


      BTW, deutsche Sprachausgabe soll hiermit gehen:

      Quellcode

      1. <speech type="cmdline" data="espeak -v de '%s'" />
      TamsPalm Deutschland - Aktuelles, News und Testberichte rund um webOS & Android.

      /// Infos, Anleitungen und Videos zu Homebrew///


      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Jonny-TX“ ()

      Jonny-TX schrieb:

      Hanspeter schrieb:

      Bei mir spricht Navit inzwischen auch Deutsch. Leider ist das nicht ganz so simple anzupassen. Mal sehen ob ich bald ein neues Paket mit deutscher Sprachausgabe zusammenstellen kann. Ich weis im Moment nicht wann ich die Zeit dazu finde.

      Könntest du die entsprechenden Dateien mal hochladen? Wäre klasse! :rolleyes:
      Das Problem liegt nicht an Navit. Navit benutzt die locale unterstützung von linus. Nur leider fehlen da im Webos einige Dateien, deshalb macht Navit einen fallback auf das eingebaute Englsiche UI.
      Wenn man die Dateien im webos nachrüstet klappt es auch mit der deutschen Sprache.
      Wir überlegen grade wie wir das mit am besten machen.

      Für alle die genügend Linux ahnung haben und es testen wollen ist es im Makefile Dokumentiert: git.webos-internals.org/?p=pre…27b35ac8e25a14bc5;hb=HEAD
      1 #
      2 # How to make localization work (maybe):
      3 #
      4 # (WARNING, this involves changes to the root-partition of your device!! You need to be very careful!)
      5 #
      6 # The C-lib expects a locale-archive in /usr/lib/locale/locale-archive.
      7 # This path is hardcoded. I don't know how to generate one, but for me the following works:
      8 #
      9 # - create dir /media/cryptofs/apps/usr/lib/locale/
      10 # - make / writable, goto /usr/lib
      11 # - create symlink to /media/cryptofs/apps/usr/lib/locale/, make / read-only again
      12 # - copy the locale-archive of your developer machine to /media/cryptofs/apps/usr/lib/locale/
      13 #
      14 # You need to adjust the LANG-variable in navit.sh
      15 #
      16 # Good luck ...
      17 #
      Wehm das nix sagt der sollte warten. Die LANG Variable auf welche du im nächsten Post verweist wird schon im Navit.sh gesetzt.

      Gruß
      HaPe

      Jonny-TX schrieb:


      BTW, deutsche Sprachausgabe soll hiermit gehen:

      Quellcode

      1. <speech type="cmdline" data="espeak -v de '%s'" />
      Bitte das nicht ändern. Das ist alles aufeinander abgestimmt. Im navit.sh giebt es eine Variable für die Strachausgabe, die kannst du auf 'de' setzten. Sie ist momentan auskommentiert. Dann bekommst du ohne die erwähnt locale fix englische Texte mit deutsche Ausspreche :)

      Quellcode

      1. 7 unset LC_ALL
      2. 8 export LANG=C
      3. 9 export ESPEAK_VOICE=en
      4. 10 export ESPEAK_SINK=pnavigation


      LANG => Sprache für UI und Navit Texte. Geht aber erst wenn locale im Webos gefixed ist.
      ESPEAK_VOICE => Aussprache von espeak

      Gruß
      HaPe

      Installation Navit !

      Hallo und einen schönen Sonntag euch allen.
      Hab da mal ne Frage bezüglich der Installation von Navit !
      Wie lange dauert denn die Installation der Datei auf meinem Pre ? Habe es nun schon ca 10 min mit dem Lapptop und dem Quickinstaller verbunden und es tut sich nix oder muß ich da einfach noch was Geduld haben ( da es ja 5 mb sind und ich nur nen Referenzzeit von den normalen Apps habe ) ?
      Mache ich ggf. was falsch bei der Installation ( sind ja auch 2 Dateien ) ?
      Wenn mir da einer nen Tipp gegeb könnte würde ich mich Freuen !

      gruß caps4476
      Also so ein 3D-Game mit 70-150 MB braucht immer so 5-10 Minuten. Navit ging bei mir in unter 1 Min.
      Hast du das SDK installliert? Wenn ja, kannst du die Installation auch via CMD versuchen

      Quellcode

      1. C:\>palm-install -d usb install PACKAGENAME
      oder so ähnlich...[MSIE_newline_end ]
      TamsPalm Deutschland - Aktuelles, News und Testberichte rund um webOS & Android.

      /// Infos, Anleitungen und Videos zu Homebrew///


      Hallo HaPe,

      vielen lieben Dank an Dich und die anderen Beteiligten an diesem Projekt.
      Endlich eine Navigation für den Palm. Die monatelange Abstinenz hat nun endlich ein Ende.
      Ich habe schon einiges mit den Konfigurationsdateien herumgespielt. Das das Aussehen den eigenen Wünschen angepasst werden kann ist einfach genial!

      Leider bekomme ich keinerlei Ton aus der Applikation heraus. Auch eine Neuinstallation hat keine Besserung gebracht.
      Hat vielleicht jemand einen Tip für mich diesbezüglich?

      Danke und Gruß,
      Dirk

      Installation Navit

      Danke schonmal für die schnelle antwort. leider bin ich im bereich was computer und installation angeht ne absolute niete. wenn ich versuche die software vie quickinstall zu installieren dauert das bis dato schon ca 10 min und das für ne dateigröße von ca 800 kb. wenn ich ein normales app installieren will geht das innerhalb von ein paar sekunden daher meine verwunderte frage ob ich da was falsch mache !